Oracle Java JDK – A more recent version of this software is required

I had previously installed Visual Studio 2015 Community Edition to do some Cordova development but was getting this message;

Oracle Java SDK A more recent version of this software is required

I downloaded the updated JDK but it wasn’t being recognised in my system. Information about this can be found here – https://msdn.microsoft.com/en-us/library/dn757054(v=vs.140).aspx#AdditionalTasks

If you modify any of the tools you are using then you need to ensure that your Environment Variables are configured correctly. A list of these variables are available here – https://msdn.microsoft.com/library/dn771551%20(v=vs.140).aspx#env_var

I chose to override the JAVA_HOME environment variable, instead of modifying them in the Computer Control Panel, to the latest version of the JDK I had installed – C:\Program Files (x86)\Java\jdk1.8.0_45. This resolved the issue for me.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s