CRM 2011 Email Router & Exchange 2010

As with all things technological the CRM Email Router I have been working with got upset when our Exchange Server  was upgraded from 2007 to 2010. After making the required changes to the Incoming Configuration for the new Exchange server I went to check the configuration using the Test Access option in the Configuration Manager. I ended up with this error;

“Incoming Status: Failure – The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel”

Which pointed me to this KB article about the problem. I could see the problem if I navigated to the Exchange web service listed in my Incoming Configuration – https://<my.exchange.server>/EWS/exchange.asmx – as I was presented with an Invalid Certificate notification.

The change in Exchange Server meant a new Certificate was issued for the new server and this needed to be installed on my CRM Email Router machine, making sure it was added to the Trusted Root Certification Authorities section. Since the certificate cannot be validated by Windows you do get a security warning, but since I know it comes from valid authority (the Exchange Server) I can install it and everything is back to normal.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s